Page 1 of 1

Companions not following

Posted: 10 Oct 2016, 14:38
by SubbDogg
So, after starting to use the numpad controls to give orders to my companions I've ran into a little problem. After the first pair of companions, who followed the numpad orders very well, died in AW. So I went back to Dead City to get some new companions, found a lonely dude, who was on the guard post behind the trader in DC, but he didn't start to follow me so I went back to AW, he did change levels, but then just sat there, so I dismissed him and got 2 guys from the merc checkpoint in AW, and they didn't want to follow me either, one of them did respond to the cover enable/disable button, but otherwise nothing. I headed to Wild Territory, there I dismissed the two guys, but they followed me after I dismissed them, just walked to whereever position I was. Asking them again to be my companions rendered them again standing statues.

I'm using the 1.4.10 patch with STCoP v1 and Smurths HUD.

EDIT: If I remember correctly my guys were on Wait command before they died, maybe that has to do with something. Also on a side note, after I make someone a companion and then dismiss them, are they still supposed to buy everything at full price?

EDIT2: S&R and escort missions have become impossible because of it, nobody wants to follow me, it seems like they are all constantly under wait order. Any way to fix it on an existing save?

Re: Companions not following

Posted: 13 Oct 2016, 09:23
by Tahvosky
Using the same addons, I too have this problem. Companions chosen by or given to me by myself or quests simply do not follow anymore. Unless I dismiss them...then they start walkin towards me all the time and everywhere I go.

The thing is...while comparing the changes both addons do to the original files: None of the seem to touch anything in the companion function. :(

I'll try to use companions in one of my earlier save and see if it still happens.

EDIT: Removed the HUD mod and NPC still don't follow. BUT: The function still works in much earlier saves...though dismissing companions still results in them slowly walking after me. :|

So is this maybe a already known bug?