Page 1 of 1

[ACDC] "stkutils::scan::get_class" get failed

Posted: 23 Jun 2017, 07:10
by anjeldavay
I tried to add new smart terrain for my new faction. When compiling new.spawn, acdc.pl get failed.

Code: Select all

FATAL ERROR!
Function: stkutils::scan::get_class
Line: 1919
Description: cannot find clsid for class smart_terrain


I've searched a lot via Yandex, but I can't find useful information. I'd like to anyone explains to me about this cause of this error.
If I want to avoid the problem, I should work with SDK, instead of using acdc. But I want to know why it happens.

My working environments:
WIndows 7 64bit
Call of pripyat 1.6.02 vanilla
acdc version 1.38
stkutils_2014-05-21
perl v5.24.1, Win32-x64 multi

The bellow code is my added line in the end of alife_jupiter_underground.ltx

Code: Select all

...
[6464]
; cse_abstract properties
section_name = smart_terrain
name = zat_sh_padonki_smart
position = 220.513509,5.282389,398.670959
direction = 0,0,0

id = 65535
version = 128
script_version = 12
spawn_id = 6234

; cse_alife_object properties
game_vertex_id = 240
distance = 7
level_vertex_id = 1340808
object_flags = 0xffffff3e
custom_data = <<END
[story_object]
story_id = zat_stalker_base_smart
[smart_terrain]
cfg = scripts\zaton\smart\zat_sh_padonki_smart.ltx
END

; cse_shape properties
shapes = 1
shape_0:type = sphere
shape_0:offset = 0,0,0
shape_0:radius = 2

; cse_alife_space_restrictor properties
restrictor_type = 3
arriving_npc =
npc_info = 0
dead_times = 0

Re: [ACDC] "stkutils::scan::get_class" get failed

Posted: 23 Jun 2017, 15:54
by AxelDominatoR
I'm not sure why you're having issues. I tried decompiling my all.spawn, pasting your code and changing the ID to make sure it's the last one, recompile and it worked.
The differences I can think of: I'm using CoC all.spawn, using acdc.pl latest version (1.4 update).
Did you make sure the ID is the first unused one, at the end of the file?

Re: [ACDC] "stkutils::scan::get_class" get failed

Posted: 24 Jun 2017, 04:15
by anjeldavay
Thank you for spending your time for my question. If the difference between my code and your code is only ID, I think it's the cause of the issue. But the truth is I don't make sense exactly which line you said about. First line [6464] or eleventh line spawn_id = 6234? I don't know what is exactly the spawn_id, and the tutorial I followed, it is posted on sigerous.ru forum, missing the spawn_id. I don't know why. So I changed both line and try compiling, but they put out the same error.

I've found the discussion about the similar problem, but I can't understand because of they are Russian. They talked about active perl version I think. I'll try to find v5.8.8. The link is here http://stalker-mods.clan.su/forum/59-28-14
Oh! I've found some posts on the amk forum just now! http://www.amk-team.ru/forum/topic/1156 ... y/?page=34
I'll try to read this one too.

Re: [ACDC] "stkutils::scan::get_class" get failed

Posted: 24 Jun 2017, 12:40
by anjeldavay
The problem solved and that is utterly stupid mistake. There are a whitespace end of the line. The compiler says that I can not find clsid for smart_terrain(+whitespace) haha. I'm ashamed of myself so I'll always enable highlight trailing spaces from now on. Thanks.

Re: [ACDC] "stkutils::scan::get_class" get failed

Posted: 24 Jun 2017, 23:37
by AxelDominatoR
Glad it worked in the end :D